PCTI Go!


Now available on the App Store and the Google Play Store!

Frequently Asked Questions


Is the app available on Android devices?

Yes! PCTI Go! is now available for both iOS and Android.

What is the minimum operating system version required?

PCTI Go! for iOS requires iOS 9.0 or newer. PCTI Go! for Android requires Ice Cream Sandwich (4.0.3) or newer.

What are the device requirements?

PCTI Go! for iOS runs on any iOS device (iPhone, iPad, iPod Touch) running iOS 9.0 or newer. PCTI Go! for Android runs on any Android phone or tablet running Ice Cream Sandwich (4.0.3) or newer.

Why does the app require Location Services?

PCTI Go!'s Campus Map feature uses Location Services to display your approximate location on the map and to determine the closest sites to your location. Your location data is never stored or shared.

Why does PCTI Go! require me to log in with my Google account to access all of its features?

Certain features are restricted to members of the PCTI community. PCTI Go! uses your Google account to verify whether you are a member of the PCTI community.

Does the app require Wi-Fi or cellular data service?

PCTI Go! does not require Wi-Fi or data to provide walking directions. Other features, including the satellite map, event calendar, daily announcements, and menus require Wi-Fi or data.

The Google Play Store says PCTI Go! is unavailable in my country.

You are logged into the Google Play Store with an account that has restricted Google Play Store access. Please log in with a different account and try accessing the Google Play Store page again.

Privacy Policy

View our privacy policy here.

Additional Support

For additional support, please contact us.