PCTI Go!

Frequently Asked Questions


Is the app available on Android devices?

At this time, PCTI Go! is only available on iOS. The Android version of PCTI Go! is currently in development.

What is the minimum operating system version required?

PCTI Go! requires iOS 8.0 or later.

What are the device requirements?

PCTI Go! runs on any iOS device (iPhone, iPad, iPod Touch) running iOS 8.0 or later.

Why does the app require Location Services?

PCTI Go!'s Campus Map feature uses Location Services to display your approximate location on the map and to determine the closest sites to your location. Your location data is never stored or shared.

Does the app require Wi-Fi or cellular data service?

PCTI Go! does not require Wi-Fi or data to provide walking directions. Other features, including the satellite map, event calendar, daily announcements, and menus require Wi-Fi or data.

How can I enable Location Services or change other app permissions?

PCTI Go! will prompt you to enable Location Services after its initial launch. If you wish to change your Location Services settings or any other permissions after dismissing this prompt, navigate to the Settings app and scroll down to find an entry labeled "PCTI Go!". Here, you can change any permissions granted to the app.

Additional Support

For additional support, please contact us.